Toyota Highlander_Trouble code P1135

josiah

Full Member
Joined
Jan 5, 2007
Messages
81
Likes
0
Points
6
#1
Please fill out the following to ask a question.

MAKE:Toyota
MODEL:Highlander
YEAR:2002
MILES:130,000
ENGINE:v6
DESCRIBE ISSUE....The Highlander failed the state emissions test. According to technician the trouble code is P1135. What is the likely cause?
Thanks.
 
Joined
Nov 14, 2006
Messages
4,910
Likes
53
Points
48
Age
119
#2
B1S1 heater circuit, have you replaced the AF sensor?
 

Attachments

josiah

Full Member
Joined
Jan 5, 2007
Messages
81
Likes
0
Points
6
#3
What is a AF sensor? Are you are talking about the Mass Air Flow sensor? If so, I have not replaced it. And I doubt it was changed previously because when I bought the vehicle certified used it was only 3 years old with appx 36,000 miles.
If we are talking about the same part, how do you test it?
Thanks.
 
Last edited:

josiah

Full Member
Joined
Jan 5, 2007
Messages
81
Likes
0
Points
6
#4
What is a AF sensor? Are you are talking about the Mass Air Flow sensor? If so, I have not replaced it. And I doubt it was changed previously because when I bought the vehicle certified used it was only 3 years old with appx 36,000 miles.
If we are talking about the same part, how do you test it?
Thanks.[/QUOTE]
 
Joined
Nov 14, 2006
Messages
4,910
Likes
53
Points
48
Age
119
#6
New
What is a AF sensor? that is Air Fuel sensor look at the info and diagrams you are getting. Its AKA oxygen sensor buta more advanced set up.
Taking a SWAG - I asked about changing component because ONLY Toyota AF sensors seem to work. Aftermarket won't work.
You say its not new so use the troubletree I attached above. Dan has a great diagram to locate sensor - should be 1-2-3 testing
 

josiah

Full Member
Joined
Jan 5, 2007
Messages
81
Likes
0
Points
6
#7
Thanks for the reply Mobile Dan and kev2.
Question, where is Bank 1 Sensor 1? The reason I ask is because I got another code reading at O'reillys and the more complete reading is P1135, B1 S1. And I noticed the illustration above is for Bank 2 Sensor 1. So where is B1 S1?
Another illustration would be a big help.
Thanks.
 

billr

wrench
Staff member
Joined
Mar 12, 2007
Messages
6,484
Likes
82
Points
48
#8
I don't have an illustration to post, but "Bank 1" (B1) is the other cylinder bank on your V-6; looks like it is the one close to the fire-wall. "Sensor 1" (S1) is the sensor between the engine and cat converter. (S2 would be between the cat and tailpipe) I expect your B1S1 will be located much like what is shown in the illustration already posted; just look on the other side of the engine.
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
9,808
Likes
178
Points
63
Location
St-Hyacinthe, Quebec, Canada
#9
Just to be more acurate, Bank 1 will always be the side that houses cylinder #1.

Many times the terminolgy can get confusing. Post cat, aft cat, pre cat, etc.

I tried to upload a snapshot, but sadly the site seems to have a problem, I can no longer upload pdf's or snashots.
 

josiah

Full Member
Joined
Jan 5, 2007
Messages
81
Likes
0
Points
6
#12
Finally back. I bought the genuine Toyota sensor as Kev2 suggested. Last Saturday I installed the sensor in the Highlander. And it passed inspection. FIXED.
Thank you much Kev2 and Mobile Dan.
What I learned:
1) Bank 1, sensor 1, is straight down between firewall and engine screwed into exhaust line. You can only access it from underneath.
2) The only part of the job that gave me some difficulty was detaching the sensor's electrical connection. It was a problem only because you can only get one hand on it. You can reach it underneath or under the hood. Either way I could only get one hand on it, and with one hand you must press the release tab and pull the connector out. The way I had to do it was to take a small screw driver and wedge it in to hold down the tab, press down with the heel of my hand on the screw driver and pull the connector out. It took a little while but I finally pulled the connector out. The rest was pretty easy, simply unscrew the old sensor with sensor wrench, test it with volt-ohm meter (it was toast), compare old sensor to new one, apply a little anti-seize to the threads of the new sensor (if you get any on the sensor wipe it off) , screw it in tight with wrench, push in the sensor electrical connector and DONE.
Thanks Guys.