PO200 (injector circuit malfunction)

Discussion in 'Domestics' started by Jim Fairbanks, Oct 21, 2011.

  1. Jim Fairbanks

    Jim Fairbanks wrench

    Joined:
    Nov 17, 2006
    Messages:
    4,381
    Likes Received:
    5
    Gender:
    Male
    Location:
    Portland,Oregon
    2001 Chevy Silverado..1500..2wd..4.3...VIN W......The truck belongs to my neighbor's dad...He brought it over and said it was running bad so he let his brother in law work on it...yeah I know....so he decides it is the injectors and replaced them with the updated style...so he says...now he says it runs worse than it did before...I scanned it and came up with the PO200 and PO300 and PO304...the cap and wires looked like crap,so I did a complete tune up on it...the PO300 and PO304 went away...it starts right up now which it would not do before.....actually runs better..but still acts like it has a miss..and the PO200 is still there..I did a fuel pressure test and when I first turn the key on the gauge goes to 60psi and as soon as the pump stops running the pressure drops to 50psi...then the fuel pressure drops to 40psi in less than 1 minute..and down to 30psi in 1 more minute.....it does take about 10 minutes for it to go to 0....I am thinking he might have messed it up installing the injectors because it ran worse after he did it, but I don't want to pull the intake unless I have to...anyone have any ideas what I should be checking....thanks....Jim
     
  2. NickD

    NickD wrench

    Joined:
    Aug 28, 2007
    Messages:
    4,308
    Likes Received:
    0
    Think the "W" uses one of these:

    [​IMG]

    If so, even the slightest vacuum leak in the upper intake manifold will cause the 4.3 L to run rough, in particular where the fuel lines run through those grommets in the lower intake manifold. Just the opposite of an SFI engine where the same kind of leak increases the idle speed, these things will run rough.

    Had just a 1/16" crack in the upper intake manifold gasket that cause this engine to run rough. Also good to replace that piece of plastic feed fuel line and getting a good seal to the regulator as a pressure leak down point. Could be a minor leak anywhere in that fuel line back to the tank or in the integrity of the fuel pump connection to the sender unit, or its check valve.

    Was told leak down to zero within 20 minutes is normal, but with a good leak proof system, will hold 50+ psi pressure for over 24 hours.
     
  3. Gus

    Gus wrench

    Joined:
    Dec 8, 2006
    Messages:
    2,389
    Likes Received:
    0
    That's the problem Jim....you don't know if the fuel pressure was acting like this BEFORE he worked on it......

    Not sure if you have rubber fuel lines or plastic ones.....if rubber, just clamp off the supply line, and see if the pressure continues to drop....if it doesn't, you know it's a possible check valve in the pump....if it does, remove clamp and pressurize again, and clamp the supply and return.....if it still drops, either injector(s), lines under plenum, or F/P regulator....

    But if vehicle starts and maintains 60 psi or more, it's not the pump causing the misfire, if P0200 is a hard code.....did he change this from a single injector system to a 6 injector system, or was it already 6 injectors and he replaced them all?
     
  4. The old man

    The old man Hero Member

    Joined:
    Aug 3, 2007
    Messages:
    806
    Likes Received:
    0
    Before I would pull the intake I would check the connector going to the injectors and check each injector control at the supply connector with a noid light to see if maybe the PCM has a bad driver on any of the injectors, especially #4 injector, which was the original code PO304. Alldata has a diagram of the connector showing you the location of the indicidual injector supply voltages. Also when you did a complete tuneup, did you notice any issues on #4 spark plug that might have suggested a problem in that cylinder? That is my $.02 worth.
     
  5. kev2

    kev2 wrench

    Joined:
    Nov 14, 2006
    Messages:
    3,755
    Likes Received:
    1
    Gender:
    Male
    DITTO on the check elec connectors - and plug appearance.... easy simple things first...

    Of course checking for a vac leak- old spray trick, If you can scan? might look at fuel trims and o2 a leaking compoent would skew these readings... might look at pending as well as misfire counter being sure that 2nd ign parts cured problem...
     
  6. Jim Fairbanks

    Jim Fairbanks wrench

    Joined:
    Nov 17, 2006
    Messages:
    4,381
    Likes Received:
    5
    Gender:
    Male
    Location:
    Portland,Oregon
    I sprayed carb cleaner around the intake with no change...oil doesn't seem to have gas in it...right Gus....I don't know what the fuel pressure was before...LOL...the fuel lines are metal...I am waiting for him to call me or come by so I can find out more about what he did...I did find out from his brother in law that he broke some plastic pieces or clips...not sure what yet...I do know that where the fuel lines go into the intake there is a lot of black silicone sealer smeared all over the whole part of that...all of the plugs looked the same when I changed them..black...like running rich...I think the miss fire is from the wires and cap...the wire and the #4 tower on the cap were all corroded...I will try to see what I can get with the readings on the scanner and post them....I really hate the ones like this when somebody else works on it first and makes it run worse then they bring it over here...thanks for all the input....Jim
     
  7. kev2

    kev2 wrench

    Joined:
    Nov 14, 2006
    Messages:
    3,755
    Likes Received:
    1
    Gender:
    Male
    Carnac the Magnificent says-


    I see a intake manifold R&R in your future... ;)
     
  8. NickD

    NickD wrench

    Joined:
    Aug 28, 2007
    Messages:
    4,308
    Likes Received:
    0
    4.3L can either have throttle body, sequential, or central manifold injection, what does this thing have? P0200 code is set if one of more injectors has low current flow, or a high resistance if you may.

    I have yet to replace a sequential metal injector, just clean them, get a varnish build up on the inside and carbon build up on the outside. Can't say that about CMFI, piece of crap plastic, find little pieces of it all over the inside of the intake manifold. See the prices of these really came down over the years.
     

Share This Page