fuel pump relay on s10

Discussion in 'Domestics' started by grizz, Apr 5, 2009.

  1. grizz

    grizz Jr. Member

    Joined:
    Jan 30, 2007
    Messages:
    25
    Likes Received:
    0
    Which of the 3 relays in the glove box is the fuel pump? 1996 s10 no power to the pump even thru the
    test wire. Maybe a relay or ground or connection prob. thanks
     
  2. Jim Fairbanks

    Jim Fairbanks wrench

    Joined:
    Nov 17, 2006
    Messages:
    4,381
    Likes Received:
    5
    Gender:
    Male
    Location:
    Portland,Oregon
    the one on the left...Have you checked the fuses?....Here is some info to help you....Jim.......Notes

    OPERATION
    When the key is turned ON with out the engine running, the control module turns a fuel pump relay ON for two seconds. This builds up fuel pressure quickly. If the engine is not started within two seconds, the control module shuts the fuel pump OFF and waits until the engine starts. As soon as the engine is cranked, the control module turns the relay ON and runs the fuel pump. When the engine is cranking or running, the control module receives the Crankshaft Position (CKP) sensor reference pulses which in turn energize the fuel injectors. As a backup system to the fuel pump relay, the fuel pump can also be turned ON by a fuel pump oil pressure switch. When the engine reaches about 28 kPa (4 psi), and the fuel pump relay does not complete the circuit, the fuel pump oil pressure switch will close to complete the circuit to run the fuel pump.

    An inoperative fuel pump relay can result in long cranking times, particularly if the engine is cold. The fuel pump oil pressure switch will turn ON the fuel pump as soon as oil pressure reaches about 28 kPa (4 psi).






    [attachment deleted by admin]
     
  3. grizz

    grizz Jr. Member

    Joined:
    Jan 30, 2007
    Messages:
    25
    Likes Received:
    0
    Thanks for the great info. I didnt realize you would bypass the relay by a long crank time.
     
  4. grizz

    grizz Jr. Member

    Joined:
    Jan 30, 2007
    Messages:
    25
    Likes Received:
    0
    More help needed. The pump relay is working, I backprobed the the gray terminal and turned the key and
    test lite lit for a few seconds. This works repeatedly. Probed the gray wire at the pump and put 12v on gray wire at relay and will not lite. Ground was run from battery to eliminate bad ground possibility. Problem
    must be in gray wire from pump to relay. Long cranking time will not lite at pump, so Im thinking problem is
    after relay and oil switch connection or one of them would cause lite to lite. Is there any plugs or connections I could check short of stripping apart the wiring harness? Thanks ???
     
  5. Jim Fairbanks

    Jim Fairbanks wrench

    Joined:
    Nov 17, 2006
    Messages:
    4,381
    Likes Received:
    5
    Gender:
    Male
    Location:
    Portland,Oregon
    Is this a 2wd?....which engine?....Jim
     
  6. grizz

    grizz Jr. Member

    Joined:
    Jan 30, 2007
    Messages:
    25
    Likes Received:
    0
    2wd 4.3 x
     
  7. Jim Fairbanks

    Jim Fairbanks wrench

    Joined:
    Nov 17, 2006
    Messages:
    4,381
    Likes Received:
    5
    Gender:
    Male
    Location:
    Portland,Oregon
    Have you tried swapping the fuel pump relay with a different one?..Have you checked the fuses?....Here is a wiring diagram of it ....Jim

    [attachment deleted by admin]
     
  8. grizz

    grizz Jr. Member

    Joined:
    Jan 30, 2007
    Messages:
    25
    Likes Received:
    0
    Yes I checked the fuses and switched out the relay. The relay works as I probed behind it on the terminal
    for the gray wire which is the hot one for the pump. The ecm is working by powering the relay for 2 sec.
    Applying 12v on the gray wire at the relay terminal doesnt show up at the pump. Since a long cranking
    time doesnt power it either, the problem is somewhere after the two are connected.
    I purchased an Alldata subsciption so maybe Ill find something there. Thanks
     
  9. grizz

    grizz Jr. Member

    Joined:
    Jan 30, 2007
    Messages:
    25
    Likes Received:
    0
    fixed As a followup I have found the problem. Started pulling wires from the harness under the truck and
    probing the gray hot wire until the test lite lit, then went back until lite wouldnt lite and narrowed it down to a lousy splice someone had made by twisting the wires together and wrapping tape around it. It was so
    corroded the wires were crumbling. Soldered in a splice with shrinkwrap and everything is fine. Ive owned
    this truck since 1996 so it was done when it was fairly new. I guess the moral of the story is if you do
    shoddy repairs it will evenually bite you or someone. On the positive side I did get an Alldata subscription.
    Thanks for the help
     
  10. Jim Fairbanks

    Jim Fairbanks wrench

    Joined:
    Nov 17, 2006
    Messages:
    4,381
    Likes Received:
    5
    Gender:
    Male
    Location:
    Portland,Oregon
    Good find....you are right...somebody Else's shoddy repairs can cause you a lot of grief...glad you got it fixed...thanks for posting back and letting us know...Jim
     
  11. JackC

    JackC wrench

    Joined:
    Nov 14, 2006
    Messages:
    1,063
    Likes Received:
    2
    Gender:
    Male
    Occupation:
    Retired
    Location:
    Nothern California
    Good for Grizz.

    It is interesting and fun to see someone like Grizz figure out his own problems, with just a little help from some one here.

    Only goes to show that all the high tech testers, etc are only helpers and that it still takes a well oiled mind to actually figure stuff out. Congratulations and as Jim said, Thanks for letting us know.

    Jack
     
  12. sunny

    sunny Hero Member

    Joined:
    Nov 14, 2006
    Messages:
    399
    Likes Received:
    0
    Grizz, as a safeguard to prevent a future corrosion problem in the gray wire you would be wise to smear a little liquid insulation on all those spots you back probed. If left exposed, the copper wire will corrode at that spot you pierced in the insulation and travel up the wire inside the insulation which will make it a bear to find later.
     

Share This Page