2007 Nissan frontier abs issues

Discussion in 'Import Vehicles' started by toolhawk, Dec 17, 2017.

  1. toolhawk

    toolhawk Full Member

    Joined:
    Mar 3, 2007
    Messages:
    95
    Likes Received:
    0
    2007 Nissan frontier, 2nd , 100,000 miles
    When braking normally brakes will make a horrendous noise and you feel it in the pedal as the ABS is being activated but not needed . And other times everything works as it should perfect and smooth, disconnecting the ABS fuse and there were no issues, reconnected and it started it again, again only happens occasionally. wheel speed sensors? Or? Thanks!!!
     
  2. kev2

    kev2 wrench

    Joined:
    Nov 14, 2006
    Messages:
    4,734
    Likes Received:
    44
    Gender:
    Male
    I would scan for codes, will need a ABS capable scanner.
    Any other issues - speedo, ANY codes?
    Anyhting recent - new tires, flat, deep water, ?

    Did Pulling the fuse get a ABS light? Hopefully ____ yes...
     
  3. toolhawk

    toolhawk Full Member

    Joined:
    Mar 3, 2007
    Messages:
    95
    Likes Received:
    0
    No new anything, tires , brakes, flats...speedo works..abs light came on only when fuse pulled , I will get codes if any
     
  4. nickb2

    nickb2 Wrench. I help when I can

    Joined:
    Nov 22, 2008
    Messages:
    8,047
    Likes Received:
    117
    Gender:
    Male
    Occupation:
    Diagnostic tech
    Location:
    St-Hyacinthe, Quebec, Canada
    Most probably a dirty or damaged wheel speed sensor.
     

Share This Page