2004 chevy cavalier

Discussion in 'Domestics' started by Tom Pepera, Apr 20, 2017.

  1. Tom Pepera

    Tom Pepera Newbie

    Joined:
    Apr 20, 2017
    Messages:
    2
    Likes Received:
    0
    Gender:
    Male
    Please fill out the following to ask a question.

    MAKE: chevrolet
    MODEL: cavalier
    YEAR: 2004
    MILES: 209000
    ENGINE: 2,2 ecotech
    DESCRIBE ISSUE....suddenly lost reverse, 1st 3rd and 4th gears (auto trans) dtc set with codes p0756 p0730 p0530 u1000 u1064 and c 1275. now the u1000 and u1064 I suspect are from the oem radio not being present . c1275 is that the trac off has been requested by the ecm. the p0530 is a/c related (it doesn't work). p0530 is a kinda generic code for incorrect gear ratio which leaves the biggie..p0756 shift solenoid "b" performance or stuck off. had a local shop put her on the rack and check the fluid..level and quality appears fine. When they went to pull it out....found the trans is locked in reverse and neutral....had to drag her out of the bay. car drives in second only. Any ideas?
     
  2. billr

    billr wrench Staff Member

    Joined:
    Mar 12, 2007
    Messages:
    5,729
    Likes Received:
    55
    I'm confused: you say it is "locked in R and N", but drives in 2nd. Those sound like conflicting symptoms. If it is "locked in R", how do you get it to N or 2nd; same for "locked in N", how do you get it to R or 2nd?
     
  3. Tom Pepera

    Tom Pepera Newbie

    Joined:
    Apr 20, 2017
    Messages:
    2
    Likes Received:
    0
    Gender:
    Male
    Guess I wasn't as clear as I thought. Car drives but only has 2nd gear. Put in any forward gear and you get 2nd only. Put in reverse and engine revs but zero movement. If you out it in neutral or reverse and attempt to push it (like they tried at the shop) and the wheels are locked. It rocks a few inches but that's it. The only way the car moves is in a forward gear and only in second (it skips 1st). Anything else acts like it's in park.
     
  4. billr

    billr wrench Staff Member

    Joined:
    Mar 12, 2007
    Messages:
    5,729
    Likes Received:
    55
    Our trans specialist may not see this right away because it isn't in the Trans forum, but he should join in fairly soon.

    If you don't want to wait, here is a long-shot to start pinning this down: disconnect all electrical cables connected to the trans. This should put the trans in a "limp home" mode such that R, N, and one forward gear (probably the highest one) will work normally. If there is no changing doing that, then I think this is unlikely to be *just* an electrical problem.

    A pure guess is that there is a sliding gear in the trans that moves to engage either the R gearing or the forward gearing and that sliding gear is in "mid-position", maybe there is a servo (hydraulic cylinder) to move that gear that is having trouble.
     
  5. kev2

    kev2 wrench

    Joined:
    Nov 14, 2006
    Messages:
    4,560
    Likes Received:
    34
    Gender:
    Male
    The 2-3 shift solenoid (SS) valve is a normally-open exhaust valve,
    P756 The 2-3 valve NO is stuck on (closed).
    The solenoid is a electrically controlled by grounding control side of circuit ,
    maybe you could confirm that the 2-3 solenoid is not being grounded - commanded on.
    How is your electrical troubleshooting - using a wiring diagram, DVOM ?

    Most likely a internal (trans valve body) issue spool sticking or spring.

    Your 1st post - alludes to vague incorrect gear ratio of code ? I think you were referring to p0730
     
    Last edited: Apr 21, 2017

Share This Page