Recent content by Eric1974

  1. E

    84 Monte Carlo stalled and would not restart.

    Yeah it has the EGR I had put a new one on 3 years ago as well when I did all that work to it.
  2. E

    84 Monte Carlo stalled and would not restart.

    Mechanical I believe. Car has the computer in it. Very primitive, first year for it I think. Electronic distributor, not vacuum. I will get a compression tester off a friend and check that to eliminate that possibility as well.
  3. E

    84 Monte Carlo stalled and would not restart.

    Fuel filter that's inside the carburetor right where the fuel line goes in.
  4. E

    84 Monte Carlo stalled and would not restart.

    No I have not checked that. I don't have a tester right now. Checked the cap and rotor on the distributor still looks new, put a couple new plug offs on the carburetor that I discovered were dry rotted nearly off and put a new fuel filter in it while I was at it. Can't keep the thing running...
  5. E

    84 Monte Carlo stalled and would not restart.

    Well I put the new fuel pump on and am getting fuel to the carburetor again and tried to start it but it would not stay running. Plugs were severely fouled out so I replaced those and it still is running bad so there is other problems going on now. It's like like I'm back to where I was when I...
  6. E

    84 Monte Carlo stalled and would not restart.

    I took the fuel line off the carburetor a little bit ago and it's dry as a bone. Literally no gas at all not even a sign of any wetness at all.
  7. E

    84 Monte Carlo stalled and would not restart.

    Got the car out for the first time this year it gets stored in the winter and occasionally gets started up during the cold months but the battery was still dead. I was not as on it as I should have been. No problem, buddy jumped me and let it run for a good bit and started fine after that...
  8. E

    2004 GMC Sierra dash lights go off and on.

    Please fill out the following to ask a question. MAKE:GMC Truck MODEL:Sierra YEAR:2004 MILES:160000 ENGINE:V6 This truck belongs to a friend. He said when he is driving the dash lights turn on and off randomly. Probably hitting bumps I'm guessing. Was thinking dimer switch maybe? I got the info...
  9. E

    Buick 3.1 Coolant leak

    I will check both areas. It's very elusive and hard to tell when it's a leak coming from the intake because it is so hidden and looks like it is coming from the water pump. (which I have not been able to determine yet) But in this case it should not be considering I just put a pump on it mid...
  10. E

    Buick 3.1 Coolant leak

    Please fill out the following to ask a question. MAKE:Buick MODEL:Century Custom YEAR:1999 MILES:200000 ish ENGINE:3.1 I have replaced the cracked overflow tank, new water pump, and new thermostat. Intake gasket was replaced about 4 years ago. No idea where it is coming from but when it is cold...
  11. E

    2000 Jeep Cherokee 4.0, auto, 125,000 mi.

    Here is just an idea. I had the same problem when I first bought my 2000 Jeep Cherokee with the 4.0. It was from California and has the emissions for that state. I fueled it up with 87 octane just like anyone would do and it was throwing cylinder miss codes. I replaced a few minor things...
  12. E

    Starter with Remote start install

    Got ya, thanks much.
  13. E

    Starter with Remote start install

    Please fill out the following to ask a question. MAKE:Buick MODEL:Century Custom YEAR:1999 MILES:Approx 200000 ENGINE:3.1 Just have a question. I have replaced plenty of starters but I have never replaced one that had the remote start. Is there anything different with this type of replacement...
  14. E

    Problematic Headlights and Turn signal On 99 Buick

    I got it figured out. It was the Multi switch/turn signal. I would have never guessed it was linked to the headlights. Figured I'd post this as solved. Thanks for the other reply too.
  15. E

    Problematic Headlights and Turn signal On 99 Buick

    Well, with everything I've done so far it seems to point to the Multi switch as the possible culprit. Got one from advance and going to attempt to install it tomorrow.