Get an AlldataDIY Repair Info Subscription Special Thanks To: AC Kits.com

Author Topic: 94 Ranger CA Smog(NOX) 15mph fail.  (Read 1105 times)

Offline twicelow

  • Full Member
  • ***
  • Posts: 85
94 Ranger CA Smog(NOX) 15mph fail.
« on: August 06, 2008, 11:05:49 PM »
Vehicle is a '94 Ranger XLT, w/ 3.0 liter eng, auto trans w/153K miles. Failed the smog NOX test (barely) at the 15 mph test level. Reqmts (   ) and readings are:
                              HC            CO             NOX                CO2            O2           RPM
15 MPH                (80) 56       (0.66) 0.32     (517) 520         15.2           0.3          1893
25 MPH                (54) 38       (0.80) 0.22     (770) 378         15.2           0.2           1836
 
I don't know how they load the dyno, put in a certain % grade or what? Judging from the rpm, it appears that at 25 mph, the truck shifted into a higher gear, probably 2nd. So it appears the problem is in 1st gear. My question is, what is the most likely cause for this NOX level? I know that the higher NOX levels are attributed to high combustion temps. EGR issues? Oxygen sensor? Catalyctic converter?(hope not). By the way, no check engine light problems, so there are no codes. The problem is now I have to take it in to an official "Gold Shield" smog repair shop for repair. Additional info: in '06 the 15 mph NOX reading was 502, It just passed. The other readings were pretty much the same. So what happenned in 2years and 7K miles. Am I a victim in the normal variation in test equipment? The change is less than 4% and  I realize it was marginal pass in the first place. In '04, 124 K miles, the reading was 279. So there was significant jump in that time frame. Any ideas on what is happenning?

Offline twicelow

  • Full Member
  • ***
  • Posts: 85
Re: 94 Ranger CA Smog(NOX) 15mph fail.
« Reply #1 on: August 15, 2008, 09:43:36 PM »
 fixed Just an update for anybody that's interested, in case they have the same or similar problem. I checked for a possibly stuck or not working EGR valve by applying a vacuum source while the engine was idling. The engine immediately started to run rough and stumble indicating that the valve was OK. That was the extent of my trouble shooting. I had to take it in anyways since it failed the official test. Long story short: it was the catalyctic converter. The shop couldn't find anything else. O2 sensor OK, and all the otherr engine control devices. Seeing how that was the original cat (14 yrs old and 153K miles) I pretty much suspected it. New test: passed with flying colors.

                             HC            CO             NOX                CO2            O2           RPM
15 MPH                (80) 41       (0.66) 0.07     (517) 136         15.5           0.1          1853
25 MPH                (54) 11       (0.80) 0.00     (770)   44         15.6           0.0          1819

It brought everything down.

 

©Copyright 2001-2013 batauto.com, BAT Auto Technical.
All Rights Reserved.
May not be reproduced without express written consent
.

Disclaimer: We cannot guarantee the accuracy of all information.
Please confirm the information with an appropriate manual
We try and make them as accurate as we can, but sometimes we all make mistakes.